2 Replies Latest reply on Aug 12, 2010 8:35 AM by József Hubert

    DFS error

    József Hubert Novice

      Hi everyone,

      We've been experiencing a strange error: in 3 out of 5 cases a generation of a document (especially with Main Agreement) dies with a 'Generic Script Error' at step 2  - "Generating document" of the document generation process. We investigated this matter and found that this only effects the situations when we use Hungarian language Windows, but couldn't reproduce when using English language OS.

      Windows has a few basic setting, something called "local and region", but tuning those settings made no difference. We tried with every possible combination of Windows XP, 2008, Vista, 7; Office 2003 and Office 2007; Internet Explorer 6, 7, 8 - in every case, we could reproduce this error.

      My question: has anybody ever met with this kind of behaviour? Any workaround, or solution for this problem is welcome.

      We're a CD customer, but tried with the on-demand product, and this "Generic Script Error" message showed up there, too.

       

      Thanks for any kind of info,

       

      Jozsef

        • Re: DFS error
          Sarah Gilsdorf Apprentice

          We have experienced generic script errors also.  A number have been related to 1) bookmarking errors, 2) having multiple instances of  Word open or 3) dfs needs to be enabled.  Always check dfs first and close out multiple Word sessions.  Otherwise:

           

          Try again - it could just be a momentary glitch.  Unfortunately, I do not know why this happens and would appreciate any enlightenment myself.

           

          If its a bookmarking error created during editing a document, turn off dfs.  You should then be able to open and save the document with changes on your computer.  Then turn on dfs and open the document in outline mode.  At that point, you can try a save which should point out the culprit bookmarks or just discard the changes in Ariba and upload the document saved elsewhere as a Word document.

           

          Not the best solution but workarounds seldom are.

           

          Sarah Gilsdorf, Analyst, Hess Corporation, Houston

          1 of 1 people found this helpful
            • Re: DFS error
              József Hubert Novice

              Hi Sarah,

               

              Thanks for the info. This unfortunately is a different issue, that can be steadily reproduced quite a few ways. Eg. every time we try to delete a clause the regeneration of the document dies with this error. Should anyone else experience the same, here is a workaround that the support team come up with (and that is working most of the time):

              1) Disable DFS.
              2) Download the Main Agreement which is in Not Generated state.
              3) Save it in your desktop.
              4) Enable DFS.
              5) Replace the Main Agreement in the contract by the document earlier saved in your desktop.
              6) Now the status of the document will be in "Draft".
              7) You can publish the Contracts now.

              We've found this method tobe working - mostly.