6 Replies Latest reply on Feb 15, 2011 11:11 AM by Sumedha Gupta

    ProfileRequest/ProfileResponse issue

    Paul O'Brien Apprentice

      I'm having an issue with our ProfileRequest/ProfileResponse exchange that I'm hoping someone can help with.  We're a supplier and I have just about everything working - order processing - order confirmations - shipping notices - invoicing and a punchout to our web-to-print system.  BUT for some reason, when I return our ProfileResponse document, the URL element for each Transaction element is blank when Ariba processes it.  We're using .Net and in the debugger, I can see that this is what I'm returning:

       

      <?xml version="1.0" encoding="UTF-8"?><!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.021/cXML.dtd"[]>
      <cXML payloadID="99c5c90c-f710-4c71-9480-6cebe59a0731@AribaLink.acculink.com" timestamp="2011-01-28T10:51:23-05:00">
              <Response>
                      <Status code="200" text="OK"/>
                      <ProfileResponse effectiveDate="2011-01-01T12:00:00-05:00">
                              <Transaction requestName="PunchOutSetupRequest">
                                      <URL>https://aribalink.acculink.com/AribaLinkPunchout/AribaLinkPunchout.asmx/PunchOutSetupRequest</URL>
                              </Transaction>
                              <Transaction requestName="OrderRequest">
                                      <URL>https://aribalink.acculink.com/AribaLink/aribalink.asmx/Request</URL>
                              </Transaction>
                              <Transaction requestName="StatusUpdateRequest">
                                      <URL>https://aribalink.acculink.com/AribaLink/aribalink.asmx/Request</URL>
                              </Transaction>
                      </ProfileResponse>
              </Response>
      </cXML>

      Hoping someone can spot something - thanks.